Forum PCLab.pl: Windows XP + SP 1 - Forum PCLab.pl

Skocz do zawarto¶ci

Otwarty

Ikona Ostatnio dodane tematy

Ikona Najnowsze pliki

Strona 1 z 1
  • Nie możesz rozpocz±ć nowego tematu
  • Nie możesz odpowiadać w tym temacie

Windows XP + SP 1 Problem ze starymi grami Oceń temat: -----

#1 Użytkownik jest niedostępny   Pawson 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 7
  • Doł±czył: Nd, 02 Sty 04

Napisany 11 Wrzesień 2005 - 11:29

Witam

Po aktualizacji XP pakietem SP 1 pojawiły sie problemy ze starymi grami. Windowsowe stare pozycja typu Outlaws albo Gearhead Garage nie chc± się nawet zainstalować bowiem "C:Windows\System 32\autoexec.nt. Ten plik systemowy nie nadaje się do uruchamiania aplikacji systemu MS-DOS lub Microsoft Windows. Wybierz przycisk "Zamknij", aby zakończyć działanie aplikacji."

Mam do wyboru przyciski Zamknij i Ignoruj. Po wyborze Ignoruj nic się nie dzieje (dobrego hehe).

Można obej¶c tę blokadę starego softu ?? Zakł±dam, że nie moge mieć na dysku starych wersji windowsa aby rozwi±zac problem (pisze o tym w dziale dot. kart graficznych).

Dzięki z góry za porady ;)
Pozdrawiam

Pawson

#2 Użytkownik jest niedostępny   maly_szcz 

  • PCLab.pl team
  • Ikona
  • Grupa: Admini
  • Postów: 26016
  • Doł±czył: Wed, 17 Sie 05

Napisany 11 Wrzesień 2005 - 11:52

Poszukać go w instalce WinXP, lub w SP i skopiować do Windows\system32. Na płycie będzie skompresowany. Poradzi sobie z tym winrar, a nawet totalcommander. Co masz w tym pliku? Wklej tu jego zawarto¶ć.

Pozdrawiam.

#3 Użytkownik jest niedostępny   Pawson 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 7
  • Doł±czył: Nd, 02 Sty 04

Napisany 11 Wrzesień 2005 - 12:07

MSCF    †      ,               H    Ć        Z+¤}  autoexec.nt áí6Ć[€€« bl  c 52 `Uđ©Ý} ?h·µ.i[·&2*#±.P€.·ĺ»\ł‰ç†/Ě=‚č˘P:™ á   ł" 
„ˆD„„gľLx(L¸ĽđÂƒĘƒ}Ů�IU€ČSćŔ,E!E˙^ďżţű 8    ¦©ůaŁ&ľ`Î_†ßßňßă9®ƒ&@/.˙˙gv±!�"†~łľ¶
0<aD5�‚b—Ň$¦׹(Ą3�Qgˇ9	EF„Tß;5ń	Ô”^Čě·
ţĘ.&Ş’Ş)ş&LEJ/-ZJ"YiJ)»7«V®ŰŃ„ăˆ((kAó~Ň„»@¶qO®Ő35¬‚A=pĽÂ°Ę±ňáƒůô†‹„ˆq–ŻßpP°JLq«Ďp¶†ÄQyQUU@Á.DNdgľÚ6$WcŐ'YW·Ąi{$-d,«xĐí™węâȦ‰Ü+ŁăčqM«A&‘qI2đ*ç'YÄ4
©n@ŕeU& ü¶ęÍěBDĘשŇëE0¨Y[(¦0+¦ ¦ăk˝Üúi»K'W‰�Ę6»™¶ŻčĽqľŰ­KÔ૵98@yql@#děŁů^'µČî ‚ţŁÄx•"üowůׯb”eSh'©L
(-ÇJłňFi:™NĆ\°Ę¶h—'Rfç\Đ·ň;ІyöÖ¶ńSąUć˘_éxĂ°-ł5[l}uCĆĄBńŞî;&9Az»éÎnĽ¶ţgkv5÷Ţ(ĂソÎőÇ™S˙Ř	żW•µ–ÝđÓ’Ôęł«#ơ·D#ĺönnÄ'Ônw39ă`ůÓ2ĺ¦Â{Ůľ«Hń¶{îĆßpŃ›Ł5¬"¤PÔ2ö˘[ňJŁoŮv´I·ˇ*¬64:ą´Ň8ű)ńJ±řP#™
řj
%5’Ţ‚éń/{�[ÖF0¶Ę›
ÓĚvU–PLÂţşpĂ­WJ	-["—/†XsË{´‹îËĽöqěąf�˝|ěFÇł>!RëáË
±°ć0ę­µ·X—!÷v˜{aÓezË®aě$ˇoŞ4·®Ăěó¤t9e|†µ


Oto zawarto¶c mojego piku autoexec.nt. Po skopiowaniu go do system32 wyrzuca mi komunikat, że plik dosx.exe musi być w autoexec.nt i w ¶cieżce wyszukiwania cokolwiek to jest....

#4 Użytkownik jest niedostępny   Gwynbleidd 

  • PAX
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 6385
  • Doł±czył: Wt, 02 Mar 04

Napisany 11 Wrzesień 2005 - 12:10

hlehle... moj wyglada tak:

@echo off

REM Plik AUTOEXEC.BAT nie jest używany do inicjacji ¶rodowiska MS-DOS.
REM AUTOEXEC.NT jest używany do inicjacji ¶rodowiska MS-DOS je¶li inny
REM plik startowy nie jest okre¶lony w pliku PIF programu.

REM Instaluj rozszerzenia CD ROM
lh %SystemRoot%\system32\mscdexnt.exe

REM Instaluj readresator sieci (ładuj przed dosx.exe)
lh %SystemRoot%\system32\redir

REM Instaluj obsługę DPMI
lh %SystemRoot%\system32\dosx

REM Poniższy wiersz wł±cza obsługę karty Sound Blaster 2.0 na NTVDM.
REM Polecenie, które ustawia ¶rodowisko BLASTER, jest następuj±ce:
REM SET BLASTER=A220 I5 D1 P330
REM gdzie:
REM A okre¶la bazowy port We/Wy karty sound blaster
REM I okre¶la wiersz ż±dania przerwania
REM D okre¶la 8-bitowy kanał DMA
REM P okre¶la bazowy port We/Wy MPU-401
REM T okre¶la type karty sound blaster
REM 1 - Sound Blaster 1.5
REM 2 - Sound Blaster Pro I
REM 3 - Sound Blaster 2.0
REM 4 - Sound Blaster Pro II
REM 6 - Sound Blaster 16/AWE 32/32/64
REM
REM Domy¶lna warto¶ć to A220 I5 D1 T3 i P330. Je¶li który¶ przeł±cznik
REM nie zostanie okre¶lony, użyta będzie warto¶ć domy¶lna. (UWAGA,
REM ponieważ wszystkie porty s± wirtualne, podane tu informacje nie musz±
REM odpowiadać prawdziwemu ustawieniu sprzętu.) NTVDM obsługuje tylko kartę
REM Sound Blaster 2.0. Je¶li przeł±cznik T jest okre¶lony, musi on być
REM ustawiony na warto¶ć 3.
SET BLASTER=A220 I5 D1 P330 T3

REM Aby wył±czyć obsługę karty sound blaster 2.0 na NTVDM, okre¶l
REM nieprawidłowy adres bazowy portu We/Wy SB. Na przykład:
REM SET BLASTER=A0

:E

Druga sprawa, plik autoexec.nt zapewne masz w katalogu: .../windows/repair ;) skopiuj go do system32 i powinno dzialac.

#5 Użytkownik jest niedostępny   maly_szcz 

  • PCLab.pl team
  • Ikona
  • Grupa: Admini
  • Postów: 26016
  • Doł±czył: Wed, 17 Sie 05

Napisany 11 Wrzesień 2005 - 12:13

A rozpakowałe¶ go jak pisałem? na płycie pewnie jest "autoexec.nt_". Nie wystarczy skopiować i zmienić rozszerzenie. Otwórz go Winrarem, lub przez totalcommandera i rozpakuj.

Pozdrawiam.

Powinno wygl±dać jako¶ tak:

@echo off

REM Plik AUTOEXEC.BAT nie jest u┐ywany do inicjacji »rodowiska MS-DOS.
REM AUTOEXEC.NT jest u┐ywany do inicjacji »rodowiska MS-DOS je»li inny
REM plik startowy nie jest okre»lony w pliku PIF programu.

REM Instaluj rozszerzenia CD ROM 
lh %SystemRoot%\system32\mscdexnt.exe

REM Instaluj readresator sieci (│aduj przed dosx.exe)
lh %SystemRoot%\system32\redir

REM Instaluj obs│ugŕ DPMI      
lh %SystemRoot%\system32\dosx

REM Poni┐szy wiersz w│╣cza obs│ugŕ karty Sound Blaster 2.0 na NTVDM.
REM Polecenie, kt·re ustawia »rodowisko BLASTER, jest nastŕpuj╣ce:
REM    SET BLASTER=A220 I5 D1 P330
REM    gdzie:
REM        A    okre»la bazowy port We/Wy karty sound blaster
REM        I    okre»la wiersz ┐╣dania przerwania
REM        D    okre»la 8-bitowy kana│ DMA
REM        P    okre»la bazowy port We/Wy MPU-401
REM        T    okre»la type karty sound blaster
REM                 1 - Sound Blaster 1.5
REM                 2 - Sound Blaster Pro I
REM                 3 - Sound Blaster 2.0
REM                 4 - Sound Blaster Pro II
REM                 6 - Sound Blaster 16/AWE 32/32/64
REM
REM    Domy»lna warto»© to A220 I5 D1 T3 i P330. Je»li kt·ry» prze│╣cznik 
REM    nie zostanie okre»lony, u┐yta bŕdzie warto»© domy»lna. (UWAGA, 
REM    poniewa┐ wszystkie porty s╣ wirtualne, podane tu informacje nie musz╣
REM    odpowiada© prawdziwemu ustawieniu sprzŕtu.) NTVDM obs│uguje tylko kartŕ 
REM    Sound Blaster 2.0. Je»li prze│╣cznik T jest okre»lony, musi on by©
REM    ustawiony na warto»© 3.
SET BLASTER=A220 I5 D1 P330 T3

REM Aby wy│╣czy© obs│ugŕ karty sound blaster 2.0 na NTVDM, okre»l
REM nieprawid│owy adres bazowy portu We/Wy SB. Na przyk│ad:
REM    SET BLASTER=A0


--edit--

Gwynbleidd byłe¶ chwilę szybszy.

Ten post był edytowany przez maly_szcz dnia: 11 Wrzesień 2005 - 12:14


#6 Użytkownik jest niedostępny   Pawson 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 7
  • Doł±czył: Nd, 02 Sty 04

Napisany 11 Wrzesień 2005 - 12:19

Dzięki za pomoc:) Problem kuriozalny, faktycznie w repair był wła¶ciwy plik autoexec.nt. jak na razie wszystko działa jak powinno :)

#7 Użytkownik jest niedostępny   januzi 

  • ^ patryjota, katolig, bochater
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 35464
  • Doł±czył: Nd, 08 Cze 03

Napisany 11 Wrzesień 2005 - 12:25

a tak apropo, wpisanie do szukaj slowa "autoexec.nt" daje te same odpowiedzi co powyzej

#8 Użytkownik jest niedostępny   Gwynbleidd 

  • PAX
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 6385
  • Doł±czył: Wt, 02 Mar 04

Napisany 11 Wrzesień 2005 - 12:25

januzi, o Sep 11 2005, 13:25, napisał(a):

a tak apropo, wpisanie do szukaj slowa "autoexec.nt" daje te same odpowiedzi co powyzej


owszem, poza tym sam zadawalem kiedys to pytanie :P

#9 Użytkownik jest niedostępny   januzi 

  • ^ patryjota, katolig, bochater
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 35464
  • Doł±czył: Nd, 08 Cze 03

Napisany 11 Wrzesień 2005 - 12:27

hmmm ... moze by tak przypiac temat ?
autoexec.nt
gadugadu
i costam jeszcze co sie najczesciej pojawia

#10 Użytkownik jest niedostępny   maly_szcz 

  • PCLab.pl team
  • Ikona
  • Grupa: Admini
  • Postów: 26016
  • Doł±czył: Wed, 17 Sie 05

Napisany 11 Wrzesień 2005 - 15:26

januzi, o Sep 11 2005, 13:27, napisał(a):

hmmm ... moze by tak przypiac temat ?
autoexec.nt
gadugadu
i costam jeszcze co sie najczesciej pojawia


Teoretycznie może być to dobry pomysł. Opisane wszystko razem.

Pozdrawiam.

#11 Użytkownik jest niedostępny   Colicab 

  • Congratulations forever
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 43014
  • Doł±czył: Wed, 02 Mar 05

Napisany 11 Wrzesień 2005 - 15:30

januzi, o Sep 11 2005, 13:27, napisał(a):

hmmm ... moze by tak przypiac temat ?
autoexec.nt
gadugadu
i costam jeszcze co sie najczesciej pojawia

"jak polaczyc 2 kompy"
"jak udostepnic neozdrade"

moje sugestie ;)

#12 Użytkownik jest niedostępny   maly_szcz 

  • PCLab.pl team
  • Ikona
  • Grupa: Admini
  • Postów: 26016
  • Doł±czył: Wed, 17 Sie 05

Napisany 11 Wrzesień 2005 - 15:38

I może ew. otwieranie plików bin/cue/iso i innych.

Pozdrawiam.

Strona 1 z 1
  • Nie możesz rozpocz±ć nowego tematu
  • Nie możesz odpowiadać w tym temacie

1 Użytkowników czyta ten temat
0 użytkowników, 1 go¶ci, 0 anonimowych