Forum PCLab.pl: Windows 7 na SM961 (Lenovo M710S)./ - Forum PCLab.pl

Skocz do zawartości

Dodaj obrazek

Otwarty

Ikona Ostatnio dodane tematy

Ikona Najnowsze pliki

  • (2 Stron)
  • +
  • 1
  • 2
  • Nie możesz rozpocząć nowego tematu
  • Nie możesz odpowiadać w tym temacie

Windows 7 na SM961 (Lenovo M710S)./ Oceń temat: -----

#1 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 11 Wrzesień 2017 - 17:47

Mam 'mały' problem, w robocie zamówili 44 sztuki Lenovo M710S na Kaby Lake'ach i5 7400 albo 7500 i zonk - okazało się że nie latają na Win 7 gdzie cala organizacja lata na jednym obrazie Windows 7 Enterprise (HP 7800-8200, tylko do biblioteki chcieli sie popisac i kupili partie nowych Lenovo za jakies 25 tys euro...).
Na mnie spadło zadanie stanięcia na głowie i wrzucenia na jedną sztukę Windows 7 Enterprise żeby firma która nam podaje obrazy OS (nie wiem jak to się po Polsku nazywa :E ) mogła na jego bazie zrobic kompletny obraz z softem i sterownikami.

Sęk w tym ze w PC siedzi Samsung SM961 NVMe, próbowałem juz slipstreamowania sterowników NVMe i albo nie dzialaja wcale (Intelowskie sterowniki) a te niby od Samsunga zaraz po "Windows is loading files" wywalają BSOD-a nvme.sys.
W BIOSie wszystko ustawione na legacy boot / CSM.

Ktoś ma jakiś pomysł? Spędziłem nad tym gratem dzisiaj już kilka h i dalej nic. Szkoda ze nie ma w nim nawet złącza SATA zeby wstawic tam zwykly dysk SSD. Dodaj obrazek

Ten post był edytowany przez czolgista778 dnia: 11 Wrzesień 2017 - 17:50


#2 Użytkownik jest niedostępny   T_G 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 6861
  • Dołączył: Pt, 19 Sie 05

Napisany 11 Wrzesień 2017 - 17:55

zainstaluj system na jakiś dysk usb, wgraj poprawki Microsoftu zawierające sterowniki do nvme, powiel system z dysku usb na wewnętrzny system programem easyus todo backup, powinien się zbootować, zresetować i działać

#3 Użytkownik jest niedostępny   mcrobert666 

  • Gaduła
  • PipPipPip
  • Grupa: Forumowicze
  • Postów: 459
  • Dołączył: Wt, 18 Wrz 07

Napisany 11 Wrzesień 2017 - 18:15

Powinien botować, zarówno z pena jak i dvd, no chyba że instalujesz z obrazu, a w uefi przestawiłeś czasem z idi na achc albo coś podobnego?

Ten post był edytowany przez mcrobert666 dnia: 11 Wrzesień 2017 - 18:18


#4 Użytkownik jest niedostępny   asino 

  • Gaduła
  • PipPipPip
  • Grupa: Forumowicze
  • Postów: 340
  • Dołączył: Nd, 09 Paź 11

Napisany 11 Wrzesień 2017 - 18:30

Tak z innej beczki - wiesz, ze Microsoft blokuje aktualizacje Windows 7 na Kaby Lake?

#5 Użytkownik jest niedostępny   MitycznyJeż 

  • bJEŻnik rozJEŻdżony
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 15067
  • Dołączył: So, 12 Kwi 14

Napisany 11 Wrzesień 2017 - 18:31

Zobacz postmcrobert666, o 11 Wrzesień 2017 - 19:15, napisał(a):

a w uefi przestawiłeś czasem z idi na achc albo coś podobnego?

To o czym piszesz to tryby pracy kontrolera SATA.
Dysk NVMe działa podpięty do magistrali PCIe, i nie ma żadnego związku z SATA.


Postaw win7 na wirtualce, zaktualizuj do reszty (by wszedł m.in. update z NVMe) (pytanie tylko czy w Twojej orgarnizacji w ogóle ona się pobiera przez WSUS...), a potem zrób klasycznie sysprep+generalize, i spróbuj taki obraz wrzucić na docelowy sprzęt.

Win7 na kebabach nie jest formalnie wspierane - miłego bujania się na betowych sterownikach do integry (jeżeli brak dedyka), i hackowania WU (jeżeli WSUS nie blokuje aktualizacji blokującej dalsze aktualizacje na zbyt nowym sprzęcie).

Ktokolwiek zadecydował o takim sprzęcie i wiedział że ma to trybić pod win7 powinien być pociągnięty do odpowiedzialności.

#6 Użytkownik jest niedostępny   MrMateczko 

  • Dyskutant
  • PipPip
  • Grupa: Forumowicze
  • Postów: 69
  • Dołączył: Nd, 16 Paź 16

Napisany 11 Wrzesień 2017 - 18:36

https://github.com/zeffy/wufuc

Sterowniki integry: ftp://europe.asrock..../VGA(v4565).zip

A, Lenovo to złom. (argumenty że to firmowe proszę odłożyć bo nie wpływają na jakość urządzeń tego producenta)

Ten post był edytowany przez MrMateczko dnia: 11 Wrzesień 2017 - 18:39


#7 Użytkownik jest niedostępny   agent_x007 

  • Mad man with a box
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 13044
  • Dołączył: Cz, 19 Mar 09

Napisany 11 Wrzesień 2017 - 18:37

Zobacz postczolgista778, o 11 Wrzesień 2017 - 18:47, napisał(a):

Sęk w tym ze w PC siedzi Samsung SM961 NVMe, próbowałem juz slipstreamowania sterowników NVMe i albo nie dzialaja wcale (Intelowskie sterowniki) a te niby od Samsunga zaraz po "Windows is loading files" wywalają BSOD-a nvme.sys.
W BIOSie wszystko ustawione na legacy boot / CSM.
Nie da się zbootować dysków NVMe w CSM/Legacy, ponieważ założę się, że Lenovo sformatowało je na GPT.
Do tego dochodzi kwestia braku obsługi NVMe w CSM/Legacy na SM961 (moduł Nvmexpressdxe jest niedostępny), ponieważ Samsung zakończył wsparcie dla trybu Legacy na dyskach 950 Pro.
Dołóż do powyższego sterowniki USB 3.0 (bez których nie uruchomisz pendrive'a, jak lapek nie posiada USB 2.0) i masz naprawdę ciekawą zagwostkę...

Jak ja to widzę : Rozbij ogarnięcie NVMe oraz instalację systemu na dwie części
1) Postaraj się wgrać Windows 7 SP1 x64 na lapku z zewnętrznym dyskiem USB/SATA (pendrive ?)
2) Kiedy ogarniesz obraz instalatora (i potrzebne mu sterowniki), przygotuj pendrive z tym obrazem ale przygotowany do uruchamiania w środowisku UEFI i dorzuć do niego sterowniki NVMe od Samsunga.
3) Jak wszystko zawiedzie : Wymontuj dysk SM961, podepnij pod zwykły komputer i na nim przeprowadź początkową część instalacji.

Jestem jednak przekonany, że korzystając z programu aktualizującego obraz obraz dysku pokroju : LINK, instalacja powinna jakość przejść :)

#8 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 11 Wrzesień 2017 - 19:18

Nie mam na nim oryginalnej instalacji Win10 bo pajacyki ktorzy przygotowuja nasze OSy się nim bawili, zainstalowali jakąś wersję Win 7 i uznali ze "nie da sie zainstalowac Windowsa 7, dziekujemy" cos namącili i ich instalacja dochodzi tylko do "Starting Windows", lapie zwis (bez BSODa) i sie resetuje, tak bez przerwy. Tryb awaryjny tez nie hula.
Problem w tym że kurde cała organizacja lata na legacy boocie ale żaden nie ma dysku NVMe, tylko HDD i SATA SSD.
Kupili partię nowych komputerów i panika bo nic nie działa a jak zawsze wszystko było na wczoraj ;)

Moj wlasny instalator z pendraka normalnie startuje ale nie znajduje zadnego dysku (poniewaz nie ma zaladowanych sterowników, wiadomo), po dograniu sterów NVMe Samsunga łapie BSODa przy samym ładowaniu plików, jeszcze przed instalatorem.
Jedyna opcja to jeszcze raz zmodyfikować obraz .ISO i wrzucić przez Rufus-a ustawionego na tryb GPT+UEFI tylko czy nie będzie problemu potem ze zainstalowaniem systemu przez PXE boot z sieci. Dodaj obrazek
Ze sterownikami USB3.0 raczej nie ma problemu skoro pendrak USB3.0 odpala, mycha USB nie działa ale to zawsze mogę doinstalować później, razem z wszystkimi sterowniki.

Co do update'ów, można go przeforsowac raz, zaktualizowac do dnia dzisiejszego i reszta mnie nie interesuje. ;) (Chyba że M$ już załatał metodę Zeffy'ego?)
Też tak myślałem żeby przełożyć dysk do innej maszyny, sztuka tylko żeby nie uwalić kolejnej.
Ogólnie to gafa jak cholera, zamówili je zaraz przed wakacjami czyli nici z jakiegokolwiek zwrotu. W najgorszym wypadku pójdą jako "Set up school PC" w Win10.

Ten post był edytowany przez czolgista778 dnia: 11 Wrzesień 2017 - 19:34


#9 Użytkownik jest niedostępny   agent_x007 

  • Mad man with a box
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 13044
  • Dołączył: Cz, 19 Mar 09

Napisany 11 Wrzesień 2017 - 19:27

Pewnie sterowniki USB...
Nie da się "uwalić" maszyny wgrywając Windows, odłącz tylko wszystkie niepotrzebne dyski twarde ;)

Możesz wgrywać Rufusa na UEFI + MBR.
Pamiętaj tylko o podmianie pliku bootx64.efi (jeżeli masz starą wersję), jeżeli zamierzasz użyć GPT/UEFI lub MBR/UEFI.

O PXE będziesz się martwił JEŻELI uda się uruchomić instalator :D

Jak mają iść "na żyletki", podeślij jednego do mnie - chętnie podłubie przy instalatorze Win 7 na takim lapku :)

Ten post był edytowany przez agent_x007 dnia: 11 Wrzesień 2017 - 19:36


#10 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 11 Wrzesień 2017 - 19:36

Drugi myk to to że do tych lenovo wchodzą tylko NVMe. Nie mają normalnego złącza SATA (zasilacz nie ma odpowiednich wyjść!).
Sterowniki mógłbym dograć po instalacji, maszyna ma porty PS/2 także nie ma problemu z myszką i klawiaturą.

p.s
To nie lapki:
Dodaj obrazek
resource://jid1-xgtdawe3yyuebq-at-jetpack/data/download_off.png

Ten post był edytowany przez czolgista778 dnia: 11 Wrzesień 2017 - 19:40


#11 Użytkownik jest niedostępny   MrMateczko 

  • Dyskutant
  • PipPip
  • Grupa: Forumowicze
  • Postów: 69
  • Dołączył: Nd, 16 Paź 16

Napisany 11 Wrzesień 2017 - 19:37

A może instalator od Win10 do instalacji Win7? (ESD)

#12 Użytkownik jest niedostępny   agent_x007 

  • Mad man with a box
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 13044
  • Dołączył: Cz, 19 Mar 09

Napisany 11 Wrzesień 2017 - 19:38

Zobacz postczolgista778, o 11 Wrzesień 2017 - 20:36, napisał(a):

Drugi myk to to że do tych lenovo wchodzą tylko NVMe. Nie mają normalnego złącza SATA (zasilacz nie ma odpowiednich wyjść!).
Dlatego wymyślono kieszenie SATA-USB ;)
Możesz zainstalować Windows'a na Penie ?

Zobacz postMrMateczko, o 11 Wrzesień 2017 - 20:37, napisał(a):

A może instalator od Win10 do instalacji Win7? (ESD)
Warto spróbować.
Próbowałeś podmieniać plik bootx64.efi ?
(w moim packu dla NVMe masz działającą wersję : LINK).

#13 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 11 Wrzesień 2017 - 19:41

Bezpośrednio na pendraku, czyli? Zainstalować go z mojejgo PC i bootować z niego OS na tym Lenovo?
Ten instalator nowej generacji do Win7 widziałem tylko na piratach z torrenta ;)

Jutro się z tym pobawię i zobaczymy co z tego wyjdzie.Dodaj obrazek

Ten post był edytowany przez czolgista778 dnia: 11 Wrzesień 2017 - 19:43


#14 Użytkownik jest niedostępny   T_G 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 6861
  • Dołączył: Pt, 19 Sie 05

Napisany 11 Wrzesień 2017 - 19:43

http://forum.noteboo...support.783469/

#15 Użytkownik jest niedostępny   agent_x007 

  • Mad man with a box
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 13044
  • Dołączył: Cz, 19 Mar 09

Napisany 11 Wrzesień 2017 - 19:47

Zobacz postczolgista778, o 11 Wrzesień 2017 - 20:41, napisał(a):

Bezpośrednio na pendraku, czyli? Zainstalować go z mojejgo PC i bootować z niego OS na tym Lenovo?
Ten instalator nowej generacji do Win7 widziałem tylko na piratach z torrenta ;)

Jutro się z tym pobawię i zobaczymy co z tego wyjdzie.Dodaj obrazek
Nowszy instalator możesz dograć do oryginalnego obrazu Windowsa przy pomocy programu od Atak_Snajpera (link do tematu masz wcześniej).
Podmiana pliku bootx64.efi powinna jednak wystarczyć aby uruchomić instalator z oryginalnego Win 7 x64 SP1 (w każdym bądź razie, mi wystarczyła :)).

Powodzenia.

#16 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 12 Wrzesień 2017 - 09:57

No to jazda, kolejna próba.

a) Zmodyfikowane ISO Windows 7 SP1 Enterprise x64 przez RT Seven Lite, dodane sterowniki NVMe i odpowiednie hotfixy jak rowniez driver Intel USB 3.0. Obraz wrzucony na pendraka przez Rufusa w trybie GPT+UEFI.

Rezultat (screen z netu ale 100% ten sam blad):
Dodaj obrazek

Ten post był edytowany przez czolgista778 dnia: 12 Wrzesień 2017 - 09:57


#17 Użytkownik jest niedostępny   agent_x007 

  • Mad man with a box
  • Ikona
  • Grupa: Moderatorzy
  • Postów: 13044
  • Dołączył: Cz, 19 Mar 09

Napisany 12 Wrzesień 2017 - 10:07

Sprawdź datę pliku bootx64.efi, który znajduje się w katalogu /EFI/Boot na nowo utworzonym penie pracującym w UEFI.
Jeżeli jest z 2010/2014, podmień na plik z mojej paczki (data 2017).

#18 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 12 Wrzesień 2017 - 10:22

Zaraz sprawdze, Rufus ustawiony jest tak:
Dodaj obrazek

#19 Użytkownik jest niedostępny   T_G 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 6861
  • Dołączył: Pt, 19 Sie 05

Napisany 12 Wrzesień 2017 - 10:44

a dlaczego nie możecie zrobić tak jak napisałem, instalacja na dysk usb a potem powielenie działającego systemu na Samsunga ? dokładnie z tym samym dyskiem laptop Della w ten sposób rozbroiłem, przy czym normalne partycje ustawiałem a nie gpt bo potem są rzeźby z ewentualnymi operacjami, czy to zwiększanie/zmniejszanie czy odzysk, backup, darmowe softy przeważnie nie obsługują

#20 Użytkownik jest niedostępny   czolgista778 

  • Uzależniony od forum
  • PipPipPipPipPip
  • Grupa: Forumowicze
  • Postów: 3282
  • Dołączył: So, 23 Maj 09

Napisany 12 Wrzesień 2017 - 10:49

Up, poniewaz na mobo mam 4 porty SATA i 0 wtyczek z zasilacza, jest tylko jedna 'mini' (jakis wlasny wymysl lenovo) do CD-ROMu.
Musialbym gdzies wygrzebac zasilacz ATX i zrobic pajaka ale oczywiscie twoja opcja jest na liscie, nie mam pod reka pendraka 16-32GB, tylko ósemki.

@agent_x007
Masz racje, jest tam stara wersja pliku:

Dodaj obrazek
+
Podmienilem bootx64.efi na Twoja wersje, teraz mieli "Loading Files", dochodzi do Starting Windows i po 2s zwisa.

Ten post był edytowany przez czolgista778 dnia: 12 Wrzesień 2017 - 11:05


  • (2 Stron)
  • +
  • 1
  • 2
  • Nie możesz rozpocząć nowego tematu
  • Nie możesz odpowiadać w tym temacie

1 Użytkowników czyta ten temat
0 użytkowników, 1 gości, 0 anonimowych