Forum PCLab.pl: Komputer nie uruchamia Linuxa - Forum PCLab.pl

Skocz do zawartości

Otwarty

Ikona Najnowsze pliki

Strona 1 z 1
  • Nie możesz rozpocząć nowego tematu
  • Nie możesz odpowiadać w tym temacie

Komputer nie uruchamia Linuxa Oceń temat: -----

#1 Użytkownik jest niedostępny   bogdanek931 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 4
  • Dołączył: Wt, 04 Gru 18

Napisany 04 Grudzień 2018 - 15:49

Witam, jetem nowy na tym forum. Mam pewien problem, mianowicie na starym komputerze (pentium g620 2x2,6, gtx 660) miałem zainstalowany Windows 7, który chodził jak chodził. Pomyslałem sobie, że zainstaluje na nim Linuxa i zacznę z nim przygodę. Po instalacji z pendrive (przebiega normalnie, nie ma problemów) wyskakuje komunikat ze zainstalowano system i zeby uruchomic ponownie komputer. Robie tak, wypinam pendrive wczesniej i nic sie nie dzieje. Wyskakuje tylko "operating system not found". Wie ktoś dlaczego tak się dzieje/jak to naprawić? Czy to dysk sie zepsuł? Próbowałem Zorin OS, Ubuntu, Minta, na każdym jest identycznie. Jak instaluje drugi raz system to w okienku wyboru partycji pokazuje mi że na dsyku jest system

#2 Użytkownik jest niedostępny   marcin_82 

  • Gaduła
  • PipPipPip
  • Grupa: Forumowicze
  • Postów: 135
  • Dołączył: Pt, 12 Wrz 14

Napisany 04 Grudzień 2018 - 17:19

Uruchom system live, pobierz, uruchom i podaj wynik skryptu bootinfoscript:
https://sourceforge....bootinfoscript/ .

W plikach masz opis jak to zrobić. Potrzebny jest wynik - RESULTS.txt.

#3 Użytkownik jest niedostępny   bogdanek931 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 4
  • Dołączył: Wt, 04 Gru 18

Napisany 04 Grudzień 2018 - 21:04

Gdy wpisuje podana w pliku komende sudo ./bootinfoscript <outputfile> to wyskakuje tylko "syntax error near unexpected token `newline'". Co powinienem zrobic? Uprzedzam ze jestem kompletnie zielony jesli chodzi o linux

#4 Użytkownik jest niedostępny   marcin_82 

  • Gaduła
  • PipPipPip
  • Grupa: Forumowicze
  • Postów: 135
  • Dołączył: Pt, 12 Wrz 14

Napisany 04 Grudzień 2018 - 22:12

No to zrób tak - po kolei w konsoli:
sudo su -

wget https://sourceforge.net/projects/bootinfoscript/files/bootinfoscript/0.61/bootinfoscript-061.tar.gz

tar xf bootinfoscript-061.tar.gz

Uruchomienie skryptu:
./bootinfoscript


Kolejne polecenie wyśle plik na serwer typu pastebin.com i wygeneruje link - podaj ten link na forum:
cat RESULTS.txt | curl -F c=@- https://ptpb.pw 


#5 Użytkownik jest niedostępny   bogdanek931 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 4
  • Dołączył: Wt, 04 Gru 18

Napisany 05 Grudzień 2018 - 21:42

Zrobilem tak jak napisales, link: https://ptpb.pw/KU9v

#6 Użytkownik jest niedostępny   marcin_82 

  • Gaduła
  • PipPipPip
  • Grupa: Forumowicze
  • Postów: 135
  • Dołączył: Pt, 12 Wrz 14

Napisany 05 Grudzień 2018 - 21:57

Zobacz postbogdanek931, o 05 Grudzień 2018 - 21:42, napisał(a):

Zrobilem tak jak napisales, link: https://ptpb.pw/KU9v


Partycja EFI wymaga flag esp i boot. Ustawisz to z livecd przy użyciu programu GParted w sposób taki jak na obrazku:
https://i.ibb.co/h9Bw5Jh/zrzut.png .

Powinno wystartować.

PS
Jeśli partycje przygotował tak zaepiście instalator Minta to ta edycja powinna się nazywać "Siara" lub "Maniana". Mageia też nie jest idealna (świat RPM jedzie na Fedorze aż miło i to w zasadzie mniej lub bardziej udane klony Fedory), ale możesz spróbować.

Ten post był edytowany przez marcin_82 dnia: 05 Grudzień 2018 - 21:58


#7 Użytkownik jest niedostępny   bogdanek931 

  • Małomówny
  • Pip
  • Grupa: Forumowicze
  • Postów: 4
  • Dołączył: Wt, 04 Gru 18

Napisany 05 Grudzień 2018 - 22:19

Po odpaleniu programu i sprawdzeniu wychodzi ze juz mialem zaznaczone zarowno esp jak i boot.

#8 Użytkownik jest niedostępny   marcin_82 

  • Gaduła
  • PipPipPip
  • Grupa: Forumowicze
  • Postów: 135
  • Dołączył: Pt, 12 Wrz 14

Napisany 06 Grudzień 2018 - 17:58

Uruchom livecd; terminal, podnieś uprawnienia:
sudo su -

Potem kolejno:
mkdir -p /mnt/ubuntu

mount /dev/sda2 /mnt/ubuntu

mount /dev/sda1 /mnt/ubuntu/boot/efi

for i in /proc /sys /dev /dev/pts; do mount -B $i /mnt/ubuntu$i; done

chroot /mnt/ubuntu /bin/bash


Reinstalacja pakietu Grub:
apt-get update && apt-get install --reinstall grub-efi

grub-install /dev/sda

update-grub

Sprawdzenie czy instalacja się powiodła:
efibootmgr --verbose | grep -i mint


Opuszczenie chroot:
cd /

exit

umount -vR /mnt/ubuntu

poweroff


Uruchom ponownie komputer. Jeśli menu Gruba nie pojawi się - dowiedz się jak uruchomić tzw. Boot Menu dla twojej płyty głównej, uruchom ponownie komputer i tam sprawdź czy jest jakaś pozycja z Mintem. Jeśli Mint nie wystartuje to wiedz, że coś jest nie tak! :D


Wspomogłem się tą instrukcją, gdyż próba instalacji Ubuntu na VirtualBox celem sprawdzenia spełzła na niczym - od czasu do czasu zaglądam co w trawie piszczy...
https://wiki.debian....rubEFIReinstall .

Ten post był edytowany przez marcin_82 dnia: 06 Grudzień 2018 - 18:01


Strona 1 z 1
  • Nie możesz rozpocząć nowego tematu
  • Nie możesz odpowiadać w tym temacie

1 Użytkowników czyta ten temat
0 użytkowników, 1 gości, 0 anonimowych