Skocz do zawartości
PuchaczRolny

WAŻNE! Mikroprzycięcia z grafami RTX

Rekomendowane odpowiedzi

Zaciekawił mnie ten temat więc poszukałem trochę informacji w internecie. Przeczytałem, że Windows 10 wykorzystuje inne timery, jeżeli są dostępne. Czy to znaczy, że problem może występować tylko na określonych konfiguracjach, np. starszych procesorach lub AMD? U mnie nie ma żadnych problemów a wyłączenie HPET nie wpływa pozytywnie na wydajność. Użyłem Superposition Benchmark i nie było żadnych różnic w osiągniętych wynikach.

Edytowane przez SebastianFM

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

:o GTX1070Ti też ma problemy :lol2:

 

Zadnych nie mialem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

sprawdzilem i co? Napisz ile co powinno byc, a nie sprawdz i co? Co mam sprawdzić? Skąd mam wiedziec ile byc powinno?

query performance 10.00000 mhz

ratio skacze od 0.999 do 1.0001.

tak ma być? W biosie hpet wlaczony inaczej problemy z rebootem kompa, robilem komendami jedynie i wylaczony sterownik w menadzerze ustawien ale to ostatnie nie wiem czy cos daje czy niet.

roznica jest bo mam mniejsze spadki fpsow i nie ma takich zacinek bo wczesniej potrafilo mocno sciac np. w wiesku i spadki byly o 3-5 fpsow wieksze.

 

dołączam się do powyższego pytania, skąd mam wiedzieć czy jest włączone czy wyłączone, ratio mam 1.0000 w tym programie

Wartość QPF świadczy czy działa HPET, jednocyfrowe taktowanie lub równe 10mhz przy Win10 1809 świadczy o wyłączonym HPET.

 

Tym programikiem można sprawdzić czy HPET jest aktywny i z grubsza sprawdzić wpływ HPET na wydajność - Link

 

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

to mam 10 MHz i ratio 1.0

zrobiłem ten test , co podałeś @sideband

 

HPET wył: interval 0,022 us

włączone: 0,8 us

 

no i jakieś Timer Calls przy wyłączonym dużo większy wynik

avg fps też większy o 15 kl/s

Edytowane przez kochan4

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

U mnie QPF wynosi dokładnie 14.31818MHz więc według tego artykułu HPET jest włączony (przynajmniej w windows 7 bo w biosie nie mam odpowiedniej opcji)

 

Cytat z artykułu:

WinTimerTest is a lightweight portable program that displays timer related information to you. You should get a value of around 14.3 MHz if HPET is enabled, and less than that, usually 3.9 MHz if it is disabled

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Owszem, tyle jest na starszych platformach Intela. Nowsze mają HPET @ 20+ MHz (dokładnej wartości nie pamiętam, a sprawdzić mi się nie chce :E). Pod Siódemką HPET jest domyślnie włączony.

Edytowane przez tomcug

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Pod Siódemką HPET jest domyślnie włączony.

Masz jakieś info o tym bo na innym forum czytałem że jest wyłączony domyślnie, m. in. dlatego że nie wszystkie płyty (szczególnie te kilkuletnie, jak jeszcze nie było win 8) go obsługują.

Edytowane przez toska78

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

to mam 10 MHz i ratio 1.0

zrobiłem ten test , co podałeś @sideband

 

HPET wył: interval 0,022 us

włączone: 0,8 us

 

no i jakieś Timer Calls przy wyłączonym dużo większy wynik

avg fps też większy o 15 kl/s

Wyszło tak jak powinno, czyli lepiej bez HPET.

 

Owszem, tyle jest na starszych platformach Intela. Nowsze mają HPET @ 20+ MHz (dokładnej wartości nie pamiętam, a sprawdzić mi się nie chce :E). Pod Siódemką HPET jest domyślnie włączony.

24MHz wink.gif

 

 

Masz jakieś info o tym bo na innym forum czytałem że jest wyłączony domyślnie, m. in. dlatego że nie wszystkie płyty (szczególnie te kilkuletnie, jak jeszcze nie było win 8) go obsługują.

 

Przecież to jest wiadome od lat, że na Win7 HPET jest standardowo włączony. Jak wyłączysz to wydajność poleci lekko w dół, odpalić aplikacje i sprawdzić wink.gif

 

HPET to wspierają nawet wiekowe platformy, więc nie wiem co ty opowiadasz. Cześć płyt głównych nie ma w biosie HPET, ale nie oznacza, że go nie obsługują.

Edytowane przez sideband

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Witam, zamierzam sobie kupić właśnie rtx 2060 palit gaming pro oc i za bardzo nie rozumiem o czym piszecie ale ogarniam ze jest jakiś problem. Wytłumaczy mi ktoś o co chodzi?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wbij 1080p i zrób test CPU w jakieś grze to moment Ci wyjdą różnice.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ja miałem wyłączony HEPT w biosie

Włączyłem, wpisałem w.w komendy z 1 postu, i w benchmarku na ustawieniach graficznych jakie mam jest 51fps, a miałem mniej... i zaraz po wyjście z pomieszczenia jak kamera leci, to nad pierwszym dachem miewałem okolice 40fps, a teraz stało w 50fps.

 

Też zrobiłem test w tym benchmarku, ale to błędy pomiarowe 1fps różnicy przy fullhd.

dCQF5cT.jpg

Edytowane przez Reddzik

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

24MHz wink.gif

Sideband jak zwykle na posterunku, dzięki za uzupełnienie :cool:

 

Ja miałem wyłączony HEPT w biosie

Włączyłem, wpisałem w.w komendy z 1 postu, i w benchmarku na ustawieniach graficznych jakie mam jest 51fps, a miałem mniej... i zaraz po wyjście z pomieszczenia jak kamera leci, to nad pierwszym dachem miewałem okolice 40fps, a teraz stało w 50fps.

Szczerze powiedziawszy, nie bardzo wydaje mi się to logiczne. HPET powoduje naprawdę potężne problemy wydajnościowe (np. na Ryzenie 5 1400 i Wiedźminie 3 aktywacja użarła gdzieś 40% FPS). Gdzie w ogóle to sprawdzałeś? Ten nowy Resident Evil 2? Sprawdź, jakie podaje obciążenie GPU np. Afterburner.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Szczerze powiedziawszy, nie bardzo wydaje mi się to logiczne. HPET powoduje naprawdę potężne problemy wydajnościowe (np. na Ryzenie 5 1400 i Wiedźminie 3 aktywacja użarła gdzieś 40% FPS). Gdzie w ogóle to sprawdzałeś? Ten nowy Resident Evil 2? Sprawdź, jakie podaje obciążenie GPU np. Afterburner.

 

Przepraszam widzę, że zgubiłem "słowo" i dziwnie to zabrzmiało. Miałem na myśli benchmark w grze Assassin's Creed Odyssey, jak kamera po wyjściu, skręca w lewo i przelatuje nad dachem, od momentu skręcenia kamery do dachu miałem ścinę, miałem spadek fps do okolic 40fps, a przelatując nad dachem miałem mniejszy fps niż ten teraz zauważony. W tej samej konfiguracji ustawień graficznych mam teraz 50fps, wcześniej tego nie doświadczyłem. Do tego minimalny 30fps.

 

Dlatego wrzuciłem też te screeny z tego programu, bo nie wiem jak to ma dokładnie działać, a do tego jestem zdziwiony tym wynikiem, ale dla świętego spokoju zrobię chyba zaraz test w AC Odyssey przy włączonym HPET w Windowsie, by się upewnić :hmm:

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Sprawdź, bo przy włączonym HPET (musi być także w systemie) na bank powinno być gorzej.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Sprawdziłem u siebie na komputerze, czystym Windows 10 17763.253 i najnowszych sterownikach. Uruchomiłem Wiedźmin 3 Krew i wino w niskich ustawieniach i rozdzielczości 1024 x 768 tak aby jak najmocniej obciążyć procesor. W moim miejscu testowym miałem średnio 350 FPS. Po wymuszeniu korzystania przez system z HPET za pomocą bcedit.exe (bcdedit.exe /set useplatformclock true) i ponownym uruchomieniu komputera ilość klatek spadła do 90.

Edytowane przez SebastianFM

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Miałem w biosie HPET wyłączone, ten lepszy wynik pojawił się po tym jak go w biosie włączyłem, a komendą wyłączyłem w Windowsie.

Do tego ustawiłem plan zasilania na Wysoka Wydajność.

Teraz zrobiłem test tego benchmarka od HPET i w 1280x720 mam tylko 2fps na korzyść OFF. W tym benchmarku procek leci na maks zegarami, ale procentowe użycie na pół gwizdka.

 

A Assassin jest dosyć dziwny, bo przy włączonym HPET uruchomiłem grę miałem w tym miejscu nad dachem 38fps, zrestartowałem grę, uruchomiłem ponownie i miałem te 50-51fps, a przecież miało być gorzej, a jest tyle ile miałem przy wyłączonym HPET w Windowsie.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

przy twojej konfiguracji to normalne, jak robisz test benchmark to bierz wyniki za 2-3 razem (8gb nisko taktowanego ramu i cep nie najszybszy)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Również włączyłem HPET w biosie i wyłączyłem komendami z poziomu windowsa.( o dziwio na B450 komputer z wyłączonym HPET nie chciał się zrestartować, przy wł. już nie ma tego problemu.)

W Watch dogs 2 brak mikroprzycięć, tak więc to działa. Wiedźmin 3 chodzi wyśmienicie tak że nie moge porównać tej gry.

I pytanie z innej beczki, przy 16GB ramu najlepiej wyłączyć pamięć wirtualną czy ustawić jakieś konkretne wartości ? Dysk ssd

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

zostaw wirtualną pamięć najlepiej na auto

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Potwierdzam mi też pomogło ale ja wyłączyłem przez menadżer urządzeń. W BFie zawsze miałem co minutę lub 2 takie tiknięcie, albo po wybraniu na mapie miejsca spownu gdy mapa się zbliżało było zawsze lekkie tiknięcie po wyłączeniu tego cały czas jest płynnie.

 

W menadżerze urządzeń jest to nazwane po polsku jest w zakładce>> Urządzenia systemowe i nazywa się Czasomierz zdarzeniowy wysokiej precyzji wystarczy to wyłączyć.

Edytowane przez Andrew2

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

W menadżerze urządzeń jest to nazwane po polsku jest w zakładce>> Urządzenia systemowe i nazywa się Czasomierz zdarzeniowy wysokiej precyzji wystarczy to wyłączyć.

Wyłączyłem to urządzenie ale i tak po restarcie mam nadal QPF 14.31818MHz czyli jakbym miał włączony HPET.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

A standardowa komenda bcdedit /deletevalue {current} useplatformclock nie działa?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

A standardowa komenda bcdedit /deletevalue {current} useplatformclock nie działa?

Działa, ale jak widać działanie tego urządzenia nie jest jednoznaczne z włączonym HPET-em.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

bzdury, placebo, zero różnicy między off/on

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...