Skocz do zawartości

Rekomendowane odpowiedzi

Napisano (edytowane)

Cześć,

mam problem z SSD. Od dwóch dni zapis dysku strasznie spadł. Z reklamowanych (i osiąganych) 1,3GB/s do ~280MB/s. Nigdy bym tego nie odkrył, gdyby nie fakt, że zapis projektów w różnych programach mi zwolnił.
Co próbowałem.
- reinstall windowsa (win 8 i win 10)
- reset BIOS i jego update
- zmiana sterowników NVMe
- wyjęcie i włożenie dysku

obraz.png.6e906be6b4567772d3f7b9f07fc4840d.png

Wiecie co może być przyczyna?
Specka:
Dysk: XPG GAMMIX S11 Pro - AGAMMIXS11-240GT-C
Z170 d3h
i5-6600k

Edytowane przez camper1x

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dysk jest jedn?

Odłącz wszystkie inne dyski i peryferia - oprócz klawichy i mychy i uruchom komputer.

Zrób test i pokaż wyniki.

 

 

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wygląda na to, że prędkość zapisu spada do poziomu, kiedy zapełnia się bufor i nie ma już sztucznego wspomagania przez cache - prędkość zapisu ok. 280 MB/s  jest typowa dla tych komórek pamięci w dyskach o tej pojemności. Jak puszczasz dwukrotny test na próbce 4 GB, to jest to już sporo jak na bufor tego dysku i może się szybko zapełniać.

Pytanie tylko, dlaczego bufor się tak szybko zapełnia? Trudno tu jednoznacznie odpowiedzieć, pewnie kontroler sobie nie radzi z optymalizacją danych, może struktura danych osiągnęła taki stopień skomplikowania, że już tego nie ogarnia? Tak to wygląda w dyskach z niższej półki, niestety. I niestety w testach najczęściej takie mankamenty nie ujawniają się, bo one wychodzą dopiero do dłuższym czasie używania dysku w warunkach realnych a nie syntetycznych. Mam MP510 240 GB i sytuacja jest podobna - raz bufor zapycha się szybciej, raz wolniej, choć w dużo mniejszym stopniu niż tutaj, tak że w moich zastosowaniach tego nie odczuwam.

Żadna z zastosowanych przez Ciebie metod raczej nie ma szans na poprawę sytuacji (no chyba że faktycznie jakieś brudne złącza, ale wątpię...). Co by mogło pomóc to upgrade firmware (jeśli takowy jest i akurat ma poprawkę na tę niedogodność) lub secure erase (choć po jakimś czasie sytuacja pewnie się powtórzy).

Jak potrzebujesz solidnego zapisu dużych ilości danych to widzę takie rozwiązania:

1. Zakupić dysk typu "PRO", który jest przystosowany to tak dużego obciążenia - przeglądnąć dokładnie testy pod względem "sustained write performance" dla dysku o konkretnej pojemności.

2. Zakupić lepszy dysk konsumencki (np. u konkurencji) i najlepiej o większej pojemności. Przy dysku 2x większym masz już 2x szybszy zapis po zapełnieniu bufora i analogicznie przy 4x, więc takie sytuacje będą dużo mniej uciążliwe.

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
11 godzin temu, leven napisał:

Dysk jest jedn?

Odłącz wszystkie inne dyski i peryferia - oprócz klawichy i mychy i uruchom komputer.

Zrób test i pokaż wyniki.

 

 

Test z linuxa z pendrive'a (live boot) pokazał dokładnie to samo.

10 godzin temu, Melon77 napisał:

 lub secure erase (choć po jakimś czasie sytuacja pewnie się powtórzy).
 

Podasz jakiś program do tego? Nadpisywałem dysk przez CMD-ome CIPHER. Bez zmian.


Niestety przy mniejszych próbkach sytuacja wygląda dokładnie tak. Samo. Niewiele po zakupie przy teście nawet 4GB prędkość zapisu dochodziła do reklamowanych 1,1-1,3 GB/s

obraz.png.1220359e8627f9590356c925b8931690.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
4 godziny temu, camper1x napisał:

Podasz jakiś program do tego?

Może SSD ToolBox: https://www.adata.com/us/ss/software-6/

4 godziny temu, camper1x napisał:

Nadpisywałem dysk przez CMD-ome CIPHER. Bez zmian.

Bo dysku ssd nie przywrócisz do stanu pierwotnego ani nie wyczyścisz struktur wewnętrznych przez nadpisywanie czegokolwiek, nawet zer. Tylko secure erase może to zrobić.

4 godziny temu, camper1x napisał:

Niestety przy mniejszych próbkach sytuacja wygląda dokładnie tak. Samo. Niewiele po zakupie przy teście nawet 4GB prędkość zapisu dochodziła do reklamowanych 1,1-1,3 GB/s

Najwyraźniej bufor przestał zupełnie działać. Jest szansa, że secure erase przywróci stan fabryczny, przynajmniej na jakiś czas. Jak to nie pomoże, to wymiana gwarancyjna.

Jakbyś pokazał SMART dysku, to by może jeszcze coś rozjaśniło (np. z CrystalDiskInfo)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Sprawdzę toolboxem. Wgrałem dzisiaj świeży system, więc dużo nie stracę. Natomiast zaraz po pierwszym włączenie tryb transferu pokazywał x4. Nie wiem czy Intel rapid storage nie ukrył go. Niemniej na czystym systemie + chipset driver sytuacja jest dokładnie taka sama, więc to nie wina IRST.

 

obraz.thumb.png.0983c042e62aa2152ede03fc849823a1.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Niestety toolbox nie działa z nowymi systemami. :( wziąłem inny dysk na którym jest system i z niego próbowałem wymazać tego SSD (sformatowanego).
Nie da rady. :(

obraz.png.0e57177ed8cb292a7daa963d12b97eb0.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Secure erase możesz przeprowadzić pod linuxem przy użyciu pakietu nvme-cli.

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Nie kombinuj z programami, bo tylko w systemie namieszasz.

MP510 - 3 lata użytkowania:

https://ibb.co/m05L2J9

 

Edytowane przez leven

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
11 minut temu, leven napisał:

Nie kombinuj z programami, bo tylko w systemie namieszasz.

MP510 - 3 lata użytkowania:

https://ibb.co/m05L2J9

 

Fajnie, że nowszy i droższy dysk jest szybszy...
Przed "awarią" miałem 1,1-1,3GB/s odczytu (zależy od windy i zapełnienia)

 

 

Edytowane przez camper1x

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam nowszy dysk ?

Masz inny slot na Nvme _

Jak tak, to pokombinuj.

 

Masz jakieś dziwne odczyty...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Faktycznie porażka z tym toolboxem Adaty. Ale inne firmy też dają toolboxy w postaci ciężkich i problematycznych kobył, kiedyś na starszym kompie chciałem zrobić secure erase oficjalnym narzędziem od Microna i nie zadziało, bo nie. Poczytałem jak użyć hdparm w linuxie i tam poszło bez problemu - i tą drogą bym Ci radził podążyć (nvme-cli nie używałem bo to był ssd sata). Upewnij się jeszcze czy na pewno masz w windows ustawione buforowanie zapisu dla tego dysku (domyślnie jest włączone, ale nie zaszkodzi sprawdzić).

  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Po secure erase (nvme-cli) niestety bez zmian. :(

Screenshot from 2020-07-07 18-24-44.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

To już w warunkach domowych raczej nic nie poradzisz, najwyraźniej buforowanie padło. Dysk do reklamacji.

Chyba że - nie wiem, czy sprawdzałeś dysk na innym kompie, bo to by wykluczyło czy przypadkiem coś na tym jednym sprzęcie się nie uszkodziło (np. jakiś kontroler na płycie głównej).

Edytowane przez Melon77
  • Like 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Tematy

  • Odpowiedzi

    • Nic się nie ugotuje , a opcje OC są w zakładce > Peripherals w bios i AMD Overclocking ( tylko tam wpisujemy wartości w [MHz] i [mV] oraz timingi w kodzie szestnastkowym 😜 ; co do ograniczeń dyskowych to niestety tak jest jak piszesz
    • Witam, otrzymalem kolejna sztuke monitora i nie dokonca jestem zadwolony z BLB. Sam juz nie wiem czy zostawiac czy wymieniac, najgorszy jest prawy gorno rog gdzie widac 3 wycieki. https://zapodaj.net/73144e7e09605.jpg.html
    • Na dzień dobry wysłał bym do specjalisty żeby mieć pewność czy tylko chce zrobić rodzicom na złość czy faktycznie mamy problem   Co do samej sytuacji z zatrzymaniem oglądam sobie tvn i widzę jak blokuje się samochód z " podejrzanym" skacze po dachu i generalnie prowokuje cały czas policję, a w komentarzu do tego tylko płacz, że funkcjonariusze byli brutalni- ręce opadają.
    • Jak nie będzie kręcił to nie poczuje żadnej różnicy między pamięciami o tych samych parametrach. No chyba że jedne z nich po prostu nie zadziałają Sprawdziłem asortyment moreli i widzę tam Patrioty Viper 4 3400 MHz CL16 za 309 zł, to brzmi już trochę lepiej i powinny się dać podkręcać w razie co. 
    • Po prawdzie to nie powinienem wspierać takich portów, ale się złamałem. Właśnie się pobiera, więc niebawem dołączę do beta-testów. Jakoś trzeba było wykorzystać kupon na Epicu, a to jeden z ostatnich tytułów które mam na liście życzeń (został Cyberpunk, Sekiro, dwa indyki i Bloodborne jeżeli wyjdzie na PC). Z tego co zdążyłem zobaczyć na yt w kwestii wydajności: - wbudowany benchmark nijak ma się do wydajności w samej grze- od średniej trzeba odjąć ok. 30% - GTX750Ti (odpowiednik GPU w PS4) w 1080p Low osiąga średnio 18 fps, przez co tytuł w FullHD jest niegrywalny. Dopiero w 720p Low karta osiąga ~30fps. - GTX1050Ti ładnie trzyma +30 fps przy ustawieniach Medium i relatywnie do swojej wydajności wypada chyba najlepiej z Pascali - wyżej gra dziwnie się skaluje i GTX1070 miewa miejscami problemy z utrzymaniem stałych 60 fps/Medium mimo że sprzętowo ta karta to 2,5 x 1050Ti, więc teoretycznie powinien być jeszcze "zapas" na wyższe ustawienia - wydajność kart od AMD również pozostawia wiele do życzenia- RX580 nie jest w stanie osiągnąć 60fps/1080p nawet na Low, a to jest 6,0 TFlops z tej samej stajni co starsze 1,8 TFlops w PS4 na którym gra chodzi w 30fps/1080p Medium - lepiej jest na Navi- RX5600XT pozwala na zabawę w stałych +60fps/1080p Ultra choć i w tym przypadku wydajność jest znacznie poniżej mocy oferowanej przez GPU Podsumowując- na tym tle pecetowy port RDR2 jawi się jako wybitnie zoptymalizowany tytuł. PS. Kompilacja shaderów... Kojarzy mi się z Zeldą na CEMU, choć tam w najnowszych wersjach przerzucili się na Vulkan'a i odchodzą od tego rozwiązania. Kto wie- może chińczyczy zamiast męczyć się z portem zrobili emulator? To by w dużym stopniu tłumaczyło spadek wydajności w relacji do wersji konsolowej. PS2. Hmm...
  • Aktywni użytkownicy

×
×
  • Dodaj nową pozycję...