Skocz do zawartości
dsxsoft

OpenVPN konfiguracja routingu

Rekomendowane odpowiedzi

Posiadam win serwer 19 na nim zainstalowałem i postawiłem serwer OpenVPN serwer(w biurze) ma ip 10.0.0.200. Na routerze otworzyłem port 1194 tak aby openvpn mógł działać w sieci wan. Skonfigurowałem również klienta na innym komputerze sieci(w domu) komputer klient vpn ma ip 192.168.0.11. Tunel VPN mi działa łączę się komputerem z domu do serwera OpenVPN otrzymuje ip tunelu 10.8.0.6 na maszynie w domu 192.168.0.11 lecz nie widzę innych maszyn w biurze nawet jak w cmd pinguje 10.0.0.200 to go nie widzi? Czytam ze nie mam routingu po miedzy obiema sieciami dlatego występuje problem u mnie jak moe skonfigurować routing na openvpn czytam w google stosuje rożne rozwiązania nic nie pomaga może wy macie jakieś rozwiązanie? 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Zarówno serwer jak i klient tworzą wirtualny interfejs sieciowy TUN (dev tun) na którym serwer podaje adresy klientom z sieci 10.8.0.0/24.
W pliku konfiguracyjnym masz to opisane C:\Program Files\OpenVPN\easy-rsa\keys\server.ovpn . Masz tam też sekcję:
 

# Push routes to the client to allow it
# to reach other private subnets behind
# the server.  Remember that these
# private subnets will also need
# to know to route the OpenVPN client
# address pool (10.8.0.0/255.255.255.0)
# back to the OpenVPN server.
;push "route 192.168.10.0 255.255.255.0"
;push "route 192.168.20.0 255.255.255.0"

i musisz zrobić pusha do sieci lokalnej serwera (zakładam że maska sieci jest 24 bitowa):
push "route 10.0.0.0 255.255.255.0"

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam dodane push "route 10.0.0.0 255.255.255.0" w pliku konfiguracyjnym serwera ale to nic nie pomaga...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Juz wszystko działa na serwerze nie włączyłem routingu w rejestrze:)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeszcze mam 1 problem mianowicie po wylogowaniu z serwera lub ponownym uruchomieniu serwer nie działa trzeba sie zalogować włączyć openvpn gui i połącz wtedy działa jak to zautomatyzować? Robię według instrukcji i nic wchodze w usługi włączamam opencpn services na automatyczne uruchomianie i nic? Nawet jak wyloguje się z systemu to koniec... 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dzięki za info tak też robiłem i nic po prostu zainstalowałem starszą wersje 2.4.9 zamiast 2.5 i działa ok chyba jaki błąd w nowej wersji...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

A jak sądzicie jest to bezpieczne OpenVPN w chwili obecnej wykorzystuje VPN w firmie tak aby pracownicy mogli łączyć się z bazą danych MSSQL(z bazy korzysta program magazynowy i rozliczeniowy) na serwerze oraz dostęp do plików udostępnionych. Każdy otrzymał certyfikat wystawiony zgodnie z instrukcja https://www.itbridge.pl/baza-wiedzy/instalacja-i-konfiguracja-openvpn-w-windows oraz klucz statyczny? Serwer stoi na innym porcie niż standardowy 1194. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

"OpenVPN to działający w oparciu o protokół SSL program do zestawiana wirtualnych sieci prywatnych." Więc jest tak bezpieczny jak ogarnięci są jego użytkownicy, bo jak oni zgubią/udostępnią dane do logowania to osoba postronna może uzyskać dostęp.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...