Skocz do zawartości
robert26011988

Nie działa podświetlanie aktywnego linku HTML + CSS

Rekomendowane odpowiedzi

Napisano (edytowane)

Witam,

Proszę o pomoc ponieważ nie działa mi podkreślenie aktywnego linku i nie wiem czemu:

Co może być nie tak ?

 

Poniżej kod.

 

 

HTML:

        <div class="kontakt_menu1">
        <div class="kontakt_menu2"  style="text-align: center; font-size: 20px;"><a href="kontakt-grupaZR" class="kontakt_link"> Grupa ZŁOTE RĘCE</a></div>
        <div class="kontakt_menu"><a href="kontakt-ZRI" class="kontakt_link">ZR Inwestycje</a></div>
        <div class="kontakt_menu"><a href="kontakt-ZRZ" class="kontakt_link">PSB Mrówka Żychlin <br> Salon Łazienek</a></div>
        <div class="kontakt_menu"><a href="kontakt-ZRN" class="kontakt_link">ZR Nieruchomości</a></div>
        <div class="kontakt_menu"><a href="kontakt-ZRL" class="kontakt_link">ZR Logistyka</a></div>
        <div class="kontakt_menu"><a href="kontakt-GD" class="kontakt_link">GOLDeal Ltd</a></div>
        <div style="clear: left;"></div>
        </div>

 

CSS:
 

.kontakt_menu1{
    
    width:100%; 
    margin: 0 auto; 
    text-align: justify; 
    font-weight: bold;
    background-color: rgba(1, 1, 1, 0.4);
}

.kontakt_menu2{
    display: block;
    margin-left: auto;
  margin-right: auto; 
    padding: 5px;
    float: left; 
    text-align: center;
    width: 100%;
    min-width: 170px;
    height: 40px;
    
    
}

.kontakt_menu{
   display: block;
  margin-left: auto;
  margin-right: auto;
    float: left; 
    padding: 5px;
    text-align: center;
    width: 20%;
    min-width: 170px;
    height: 60px;
}


.kontakt_link{
    padding: 5px;
    color: white;
    text-align: center;
    text-decoration: none;
}

.kontakt_link:link{
    color: white;
    text-decoration: none;
}

.kontakt_link:actove{
    color: white;
    text-decoration: none;
    border-bottom: 2px solid white;
    transition-duration: 0s;
}

.kontakt_link:hover{
    color: white;
    text-decoration: none;
    border-bottom: 2px solid white;
    transition-duration: 0s;
}

 

 

Edytowane przez robert26011988

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem rozwiązany poprzez zmianę klasy w klikniętym linku i nowe reguły CSS dla tej klasy.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...