Skocz do zawartości
MisiekPolarny

Radeon HD 7570 i filmy fullHD na YT

Rekomendowane odpowiedzi

Hej wszystkim.

Mam problem z kartą Radeon HD 7570. Otóż nie da się na niej oglądać z YT filmów w jakości 720p i 1080p. Żeby to było możliwe, karta powinna dekodować VP9 lub H.264. Według informacji znalezionych w internecie ten Radeon dekoduje H.264 a mimo to nie działa fullHD. Korzystam z Windows 7 i Firefoxa z zainstalowanym dodatkiem h264ify. Procek to Athlon 64 X2 4400+ (s.939). Informacje o kodekach i kartach Radeon znalazłem tutaj: https://en.wikipedia.org/wiki/Video_Coding_Engine oraz tutaj: https://en.wikipedia.org/wiki/Unified_Video_Decoder#UVD_3 Czy ktoś mógłby rzucić nowe światło na sprawę?

Pozdrawiam.

Edytowane przez MisiekPolarny

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Kliknij prawym przyciskiem na filmie, daj "Statystyki dla nerdów", a potem odtwórz z 30-60 sekund filmu w 1080p i wklej screen jak wyglądają te statystyki.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

W 1080p po kilku sekundach zacinania się samoczynnie przełącza się na 480p. Jeśli chodzi o statystyki dla nerdów, to po włączeniu rozszerzenia h264ify pokazuje kodek AVC (bez rozszerzenia pokazuje VP9), czyli tak jakby faktycznie działało. Tylko że to nic nie zmienia, bo już przy 720p filmy się zacinają a co dopiero przy 1080p.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Są dwie opcje:

1. Za słaby internet dla tej rozdzielczości ? Jakie masz łącze ?

2. Firefox wyłączył akceleracje z jakiegoś powodu - można to sprawdzić wpisując w pasku adresu "about:support" i powinna być tam jakaś informacja typu "Obejścia problemów", ewentualnie kliknij tam przycisk "Skopiuj tekst do schowka" i wstaw jako plik w załączniku. Często przyczyna może być w nieaktualnych sterownikach od karty graficznej i może pomóc ich aktualizacja.

Edytowane przez MassTA

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Internet jest ok, bo na drugim kompie do gier filmy 1080p działają bez problemu. Karta sieciowa też sprawdzona.

Windows 7 jest świeży, dopiero co zainstalowany, sterowniki do grafy ściągnięte z neta, raczej najnowsze.

W Chrome sytuacja wygląda podobnie, też się tnie już przy 720p (procek stale w okolicach 100%) pomimo zainstalowanego rozszerzenia h264ify (statystyki dla nerdów pokazują AVC). Czyli to nie kwestia przeglądarki, chyba że w obu trzeba coś pozmieniać w konfiguracji.

Czyżby sterowniki do karty graficznej blokowały wykorzystanie wsparcia sprzętowego? Nie znalazłem żadnych takich ustawień w panelu sterowników.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
3 godziny temu, MisiekPolarny napisał:

Czyżby sterowniki do karty graficznej blokowały wykorzystanie wsparcia sprzętowego? Nie znalazłem żadnych takich ustawień w panelu sterowników.

Chodzi o to, że Google/Mozilla zbierają statystyki jak się wysypuje odtwarzanie wideo i jak widzą że na danej kombinacji karta graficzna/sterownik się często wysypuje, to wciągają taki sterownik na czarną listę i z automatu jest wyłączona akceleracja sprzętowa. Sterowniki do tej karty na stronie AMD są z 2015 roku, więc nie są jakieś super nowe.

Pod Chrome możesz zobaczyć status akceleracji wideo wpisując w pasku adresu "chrome://gpu/" i powinieneś mieć tabelkę z wypisanymi obsługiwanymi formatami jak w załączniku.

Jak nie ma takiej tabelki to powinna być tam informacja dlaczego nie jest dostępna akceleracja H264 w sekcji "Driver Bug Workarounds", lub "Problems Detected".

chrome_video_acceleration_information.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Sprawdziłem tak jak zasugerowaliście i po kolei:

1. Zainstalowałem przeglądarkę Slimjet i efekt jak w pozostałych przeglądarkach.

2. W Chrome wygenerowałem raport GPU (w załączniku chrome.txt) i oczywiście tabelki dekodera nie ma, ale za to w sekcji błędów jest informacja:

"Problems Detected
Raster is using a single thread.
Disabled Features: multiple_raster_threads
Gpu compositing has been disabled, either via blocklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
Disabled Features: gpu_compositing"

Czyli coś jest na rzeczy z czarną listą.

3. Odinstalowałem sterowniki i zainstalowałem Crimson Beta. Efekt nieco lepszy (na wszystkich przeglądarkach), bo wideo 720p już da się w miarę płynnie oglądać, ale 1080p niestety się tnie. Przy czym w dalszym ciągu procesor pracuje w przedziale 75-100% jakby GPU spało. Co ciekawe raport GPU w Chrome dalej nie zawiera tabelki dekodera a lista błędów jest bardzo długa (w załączniku chrome_new.txt).

Wygląda na to, że problem leży po stronie sterowników. Da się to jakoś naprawić, czy czeka mnie sprawdzanie wszystkich dostępnych w necie sterowników na chybił-trafił? :-P

 

chrome.txt chrome_new.txt

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

To że cpu jest pod korek to nic dziwnego jak siedzi tam athlon x2 ;) 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ale chyba GPU powinno go odciążyć? Ja tak rozumiem działanie sprzętowego kodeka na karcie graficznej.

Wiem, że procek jest stary, ale żal mi było go wyrzucić więc postanowiłem sprawdzić jego możliwości w małym Media Center, stąd karta graficzna low profile. Liczyłem, że odpowiednie GPU pozwoli odtwarzać video 1080p na YT.

Edytowane przez MisiekPolarny

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

W Chrome możesz spróbować zmienić opcje "chrome://flags/#ignore-gpu-blocklist" na "Enabled" - w teorii powinno pomóc bo w logu "chrome_new" masz info że jest wyłączona przez stare sterowniki, które się wieszały:

8.17.10.* AMD drivers trigger hangs in video stack: 1160623
Disabled Features: accelerated_video_decode

Możliwe że trzeba będzie dodatkowo ustawić "chrome://flags/#disable-accelerated-video-decode" na "Enabled", jeśli nie jest.

Pod Firefox powinno pomóc ustawienie w "about:config" ustawienia "media.hardware-video-decoding.force-enabled" na "true", oraz "media.wmf.skip-blacklist" takżę na "true".

  • Thanks 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ustawiłem wszystkie flagi i w chrome pojawiła się wreszcie tabelka dekodera Video Acceleration Information taka jak powinna być. Jednak ostatecznie odtwarza płynnie tylko 720p, przy 1080p ścina i procek notorycznie "obija się" o 100%, czyli tutaj prawdopodobnie jest przyczyna - kres możliwości procesora. Szkoda, bo liczyłem na więcej, ale i tak jest lepiej niż było. Chyba że macie jeszcze jakieś pomysły?

Dzięki za pomoc, dużo się dowiedziałem przy okazji :-)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Zainstaluj xp do tego cpu to trochę odetchnie albo chociaż jakąś okrojoną lżejszą wersję 7 np starter mini.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Myślałbym raczej próbować w drugą stronę - zainstalować Windows 10 i może przeglądarka będzie mogła lepiej wykorzystać kartę graficzną, bo spora część akceleracji jest z automatu wyłączona dla Windows 7. Jeden minus tej opcji to trzeba się trochę pobawić ustawieniami systemu żeby jakieś skanowania Windows Defender itp. w tle nie obciążały CPU.

Sam mam Windows 7 i kartę graficzną Geforce RTX 2060 Super, która obsługuje dekodowanie VP9, ale w przeglądarkach to nie jest wykorzystywane bo Windows 7 rzekomo ma jakiś problem, mimo że w MPC-HC bez problemu odtwarza filmy w tym zakodowane z aktywną akceleracją. :szczerbaty: Tyle że na i7 4790 odtwarza mi to i tak bez problemu, więc bez różnicy mi to.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Windowsa 10 w wersji 64 bit nie da się zainstalować na tym procesorze, bo nie posiada on jakiejś jednej instrukcji (!). Już to przerabiałem. Moim zdaniem to zwykłe ubijanie starej platformy przez MS, bo przecież siódemka 64 bit działa bez problemu. Z kolei instalowanie Win 10  32 bit w komputerze z 4GB ramu mija się z celem.

Spróbuję jeszcze pomęczyć Windowsa XP. Co prawda mam wersję 32 bit, ale jak się uda, to poszukam wersji 64 bit.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...