Skocz do zawartości
aki.

Błędy po zmianie płyty głównej - Bootmgr is corrupt, system cannot boot.

Rekomendowane odpowiedzi

Cześć,

po ostatniej awarii płyty głównej w moim starym komputerze, wymieniłem ją na nową.

Poprzednio miałem MSI B85M-E45, teraz zamówiłem Asus B85M-E i przyszła konkretnie B85M-E/DASH, cokolwiek ta końcówka znaczy. 
 

Wszystko poprzekładałem na nową płytę łącznie z dyskami. Włączam komputer i krótko po logo Asus pojawia się czarny ekran i błąd:

Bootmgr is corrupt, system cannot boot.
 

W przypadku podłączenia jakiegoś systemu z USB (mam Linuxa i Windowsa na USB oryginalnego) pojawia się inny błąd:

The file is possibly corrupt. The file header checksum does not match the computed checksum.

W przypadku Linuxa czasem pojawi się jego logo i menu. Po wybraniu jakiejkolwiek opcji rozruchu, pojawia się czarno ekran i „_” mruga w nieskończoność.

Próbowałem już wszystkiego co znalazłem na temat tego problemu. Wypinanie dysków, RAM, zmiana okablowania, zmiany w BIOS, security boot itp.

W kwestii bios to nie ma nowych aktualizacji, ta płyta od chyba 2015 roku nie ma nowych. W przypadku takiej samej płyty ale bez dopisku „/DASH” jakieś nowsze aktualizacje biosu się pojawiały. Tutaj bieda. 

Jeśli chodzi o ostatnią płytę i awarię to nastąpiło jakieś przepięcie, które uszkodziło płytę główną. Komputer działał, ale coś jakiś czas wywalało jakieś błędy i ogólnie działy się cuda. Ale system się uruchamiał. 


Jakieś sugestie co robić? Zastanawiam się czy coś źle podpiąłem, płyta jest z czymś niekompatybilna czy może podczas tamtego przepięcia coś jeszcze się uszkodziło i teraz się wysypało do końca. 
 

Komputer ma już swoje lata i jestem w trakcie realizacji zamówienia nowego, ale to trochę potrwa a ja potrzebuję aktualnie jakiś do pracy. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jakiego Windowsa tam chcesz instalować ? Może na tak starą płytę trzeba nie wyżej, jak Windows 7 ? Trzeba na próbę pobrać ISO Win 7 i stworzyć bootowalny pendrive i spróbować go odpalić.

https://winiso.pl/windows-desktop/windows-7

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

 

23 minuty temu, leven napisał:

Jakiego Windowsa tam chcesz instalować ? Może na tak starą płytę trzeba nie wyżej, jak Windows 7 ? Trzeba na próbę pobrać ISO Win 7 i stworzyć bootowalny pendrive i spróbować go odpalić.

https://winiso.pl/windows-desktop/windows-7


Windows 10. Wcześniej też używałem 10 przez dłuższy czas, krótko od premiery chyba i nigdy nie było problemów. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

System tu raczej nic do gadania nie ma. Ile masz dysków podłączonych? Przypadkiem razem z płytą któryś dysk z systemem też mógł odejść w zaświaty. Ja swego czasu w starym kompie po dołożeniu ssd wszystko działało, kiedy przeniosłem kompa do innego mieszkania, a nie było nic w środku ruszane, zaczęły się problemy z bootowaniem, musiałem odłączyć starego hdd i zostawić ssd, później jak podłączyłem hdd to już nie ma problemu :) 

Edytowane przez AndrzejTrg

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
11 minut temu, AndrzejTrg napisał:

System tu raczej nic do gadania nie ma. Ile masz dysków podłączonych? Przypadkiem razem z płytą któryś dysk z systemem też mógł odejść w zaświaty. Ja swego czasu w starym kompie po dołożeniu ssd wszystko działało, kiedy przeniosłem kompa do innego mieszkania, a nie było nic w środku ruszane, zaczęły się problemy z bootowaniem, musiałem odłączyć starego hdd i zostawić ssd, później jak podłączyłem hdd to już nie ma problemu :) 

Mam 2 dyski. Ssd i hdd. Próbowałem odłączać na zmianę albo oba na raz i uruchamiać z USB, bez zmian. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Próbowałem działać bez karty graficznej, hdmi zamiast dp - bez zmian.

 

Uruchomiłem z CSM ze zmienionymi ustawieniami. W przypadku security boot jako inny os (nie Windows), nie widzi windowsa z dysku i pendrive. Jeśli chodzi o linuxa, to menu włącza się w inny sposób, a po uruchomieniu Start lub jako compatible mode jest tylko czarny ekran i nic się nie dzieje.

Wracając do sprzętu - jedyne czego nie podpiąłem to jest to jeden wentylator z tyłu obudowy. Wyjście ma 3 pinowe, a na płycie jest 4 pinowe gniazdo. Ale to chyba nie powinno psuć roboty?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wentylator nie ma nic wspólnego z bootowaniem systemu. Dziwne, że bios nie rozpoznaje bootowalnego pendrive. Wygląda na to, że w biosie coś trzeba przestawić, żeby rozpoznawał ISO z pena. W manualu nie ma nic na temat botowania ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Zrestartuj bios poprzez wyciągnięcie baterii na 5 min.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
11 godzin temu, leven napisał:

Wentylator nie ma nic wspólnego z bootowaniem systemu. Dziwne, że bios nie rozpoznaje bootowalnego pendrive. Wygląda na to, że w biosie coś trzeba przestawić, żeby rozpoznawał ISO z pena. W manualu nie ma nic na temat botowania ?

Sprawdzałem, nic konkretnego. Ustawiałem na różne sposoby m.in. CSM i inne. Bez zmian

 

18 minut temu, AndrzejTrg napisał:

Zrestartuj bios poprzez wyciągnięcie baterii na 5 min.

Przerabiałem to też, nic nie pomogło. 
 

 

Jeśli dobrze to rozumiem - poprzednia płyta główna miała bios w trybie UEFI (kolorowy interfejs itp). Aktualna ma chyba w trybie legacy czyli ten prosty z sterowaniem tylko klawiaturą. Nie wiem czy to może mieć jakiś wpływ na ogólny problem. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Może i ma, pena masz pod uefi, system na dysku tak samo - a płyta bootuje legacy. Jedyna opcja to zrobić pena z windowsem pod opcję bez uefi i wgrać od nowa system, lub pogrzebać w biosie czy nie możesz tam uefi właczyć.

Pod zakładką CSM:

image.png.80361d2a29abba3ddf93acbdec8376ae.png

Boot devices control - jak wybierzesz uefi only to coś się zmienia?

Edytowane przez Qrdello

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Godzinę temu, Qrdello napisał:

Może i ma, pena masz pod uefi, system na dysku tak samo - a płyta bootuje legacy. Jedyna opcja to zrobić pena z windowsem pod opcję bez uefi i wgrać od nowa system, lub pogrzebać w biosie czy nie możesz tam uefi właczyć.

Pod zakładką CSM:

image.png.80361d2a29abba3ddf93acbdec8376ae.png

Boot devices control - jak wybierzesz uefi only to coś się zmienia?

Sprawdzałem tylko pod uefi, tylko pod legacy i mieszane opcje. Albo wyrzuca błąd, albo w ogóle nie widzi dysku, pendrive z windowsem. Z linuxem odpali menu ale nie odpala i nie instaluje linuxa z żadnej opcji.

 

Komputer dałem do serwisanta na diagnostykę. Zobaczymy czy czasem coś jeszcze się nie uszkodziło fizycznie. Albo ja popełniłem jakiś błąd w montażu lub ustawieniach. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wracam od serwisanta. Diagnoza - uszkodzona płyta główna.

I w sumie ciekawe, bo dwie płyty główne które miałem wywalały ten sam błąd. Zastanawiam się teraz co jest tego powodem:

- uszkodzenia fizyczne płyty głównej wyrzucają ten sam błąd,

albo

- oba biosy płyt były źle skonfigurowane odnośnie bootowania. I to w sumie jest ciekawy przypadek, bo: moja płyta główna podobno uległa uszkodzeniu gdy miałem przepięcie prądowe. Ogólnie szło włączyć komputer, windows się uruchamiał ale działał coś koślawo, różne rzeczy się działy. Głównie w kwestii sieci i internetu ostro się bugowało itp. Gdy przełożyłem płytę główną na „nową” to miałem problem właśnie z tym błędem co w temacie. Odesłałem płytę. Założyłem z powrotem swoją, ale przy przekładaniu zmieniłem baterie na płycie i zresetował się przez to bios. Włączając komputer, pokazał się ten sam błąd niepozwalający uruchomienie systemu.

albo

- podczas diagnostyki płyt nie wiem czy diagnosta przekładał procesor na jakiś inny. Jeśli nie, to jest jeszcze opcja, że to właśnie procesor jest uszkodzony od tamtego przepięcia i psuje robotę. Albo jakiś inny element płyty, podzespół (ale diagnosta przekładał m.in. ramy na swoje. Nie wiem jak z prockiem). Niestety nie mam możliwości przełożenia na inny sprawny żeby to sprawdzić. 
 

Tak czy inaczej - odpuszczam sobie już ewentualną naprawę komputera. Szkoda mi już czasu i kasy na inwestowanie w tego staruszka. Pora na wymianę :) 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...