Skocz do zawartości
Michał_86

Excel

Rekomendowane odpowiedzi

Cześć, potrzebuję pomóc kobiecie w rozwiązaniu zadania. Ja niestety leżę z excela więc liczę na was. Przeszukałem pomoc MS ale nadal nie wiem z jakiej strony to ugryźć. Oto treść zadania:

 

W a1 wpisz dowolną datę rrrr-mm-dd

W a2 umieść wyrażenie które wyświetli: osoba pelnoletnia gdy w a1 bedzie wpisana data osoby majacej 18 lat i osoba nie pelnoletnia w przeciwnym przypadku.

W zadaniu należy wykorzystać funkcję ROK

 

Będe wdzięczny za nakierowanie na rozwiązanie.

Edytowane przez Michał_86

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

=JEŻELI(ROK(DZIŚ())-ROK(A1)>18;"Osoba pełnoletnia";JEŻELI(ORAZ(ROK(DZIŚ())-18=ROK(A1);MIESIĄC(DZIŚ())>MIESIĄC(A1));"Osoba pełnoletnia";JEŻELI(ORAZ(ROK(DZIŚ())-18=ROK(A1);MIESIĄC(DZIŚ())=MIESIĄC(A1);DZIEŃ(DZIŚ())>=DZIEŃ(A1));"Osoba pełnoletnia";"Młodociany")))

To powinno załatwić temat...

Żeby zadziałało musisz w komórce a1 ustawić format na datę.

Edytowane przez staffer

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
=JEŻELI(ROK(DZIŚ())-ROK(A1)>18;"Osoba pełnoletnia";JEŻELI(ORAZ(ROK(DZIŚ())-18=ROK(A1);MIESIĄC(DZIŚ())>MIESIĄC(A1));"Osoba pełnoletnia";JEŻELI(ORAZ(ROK(DZIŚ())-18=ROK(A1);MIESIĄC(DZIŚ())=MIESIĄC(A1);DZIEŃ(DZIŚ())>=DZIEŃ(A1));"Osoba pełnoletnia";"Młodociany")))

To powinno załatwić temat...

Żeby zadziałało musisz w komórce a1 ustawić format na datę.

 

 

 

OMG :thumbdown: a co to za tasiemiec? wpisz sobie takie kilkanaście znaczków:

 

=JEŻELI(DATA(ROK(A1)+18;MIESIĄC(A1);DZIEŃ(A1))>DZIŚ();"niepełnoletni";"pełnoletni")

 

Pzdr.

P.S. A potem się dziwicie, że przy takiej jak powyższa optymalizacji, gry Wam sprzęty zarzynają

Edytowane przez ghs

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
OMG :thumbdown: a co to za tasiemiec? wpisz sobie takie kilkanaście znaczków:

 

=JEŻELI(DATA(ROK(A1)+18;MIESIĄC(A1);DZIEŃ(A1))>DZIŚ();"niepełnoletni";"pełnoletni")

 

Pzdr.

P.S. A potem się dziwicie, że przy takiej jak powyższa optymalizacji, gry Wam sprzęty zarzynają

Jak to czasami bywa patrząc na szybko nie zauważyłem prostszej opcji, druga kwestia to fakt, że rzadko korzystam z funkcji excela, więc zrobiłem wersję, która będzie działała w myśl zasady, że jeśli to nie przemysł to lepsza wersja która działa dobrze, ale średnio optymalnie, niż taka która nie działa w ogóle ;)

 

Nie musisz pisać takich łzawych PSów, przecież widać, że nie jestem programistą :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Witam,

 

Przepraszam, że odświeżam temat ale akurat bawię się w Excelu i można również użyć takiej formuły do sprawdzenia pełnoletności:

 

=JEŻELI(((DZIŚ()-A1)/(365,25))>18; "pełnoletni"; "niepełnoletni")

 

Formuła liczy dni pomiędzy dniem dzisiejszym, a dniem urodzenia, następnie dzieli otrzymaną wartość przez 365,25 (jest to uwzględnienie roku przestępnego) i sprawdza czy jest większa lub równa 18. Może komuś się przyda.

 

PS. Data urodzenia w komórce A1 musi mieć postać RRRR-MM-DD (rok-miesiąc-dzień).

Edytowane przez fontanero

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Tematy

  • Odpowiedzi

    • Możesz się nastawić na wymianę pieca raz na 10-15lat. Dłuższe używanie może być nieekonomiczne z czasem, jak poprawi się technologia a nasz piec się zestarzeje i zakamieni.  Sam raz zmieniałem sprawny stary kocioł gazowy na nowy. Rachunki za gaz spadły 3x. I to przy przesiadce na taki zwyklaczek z otwartą komorą spalania nie kondensacyjny.   Elektryczne też tak mają, powinno się wymieniać katodę w bojlerach. Na pewno grzałkę powinno się albo odkamienić raz na kilka lat albo wymienić. Pewnie za 10-15 lat nowe modele będą również znacznie efektywniejsze. W przepływowych nie wiem. Ale też nie będą wieczne   Co do bzdury cytowanej, daj sobie spokój. 20-24kW obsłuży ciepłą wodę na dwa krany. Wanny też napełni dwie na raz, ale wolniej. Woda w naturalny sposób będzie lała się wolniej w obu punktach. Nic więcej nie potrzeba w normalnym domu. Może jak ktoś ma dwie - trzy łazienki to montuje mocniejsze kotły i większe przekroje rur do rozprowadzania wody, ale to nie jest nic, co powinno spędzać sen z powiek kawalera Jak zrobisz ścianę z tych białych bloczków ( silkat? ), to kołki rozporowe i wieszanie zbiornika CWU o masie kilkuset kilogramów może nie przejść próby czasu. Duze zbiorniki i tak kupuje się raczej stojące. Taki zbiornik 300litrów będzie ogromny, jeżeli ma posiadać sensowną izolację. Już 80-100 litrów powieszony na ścianie ledwo mieści pralkę pod sobą.
    • Ostatnią akurat nie, jeszczę parę godzin wisiały jako dostępne po moim zakupie jeszcze przez 2 tygodnie póki czas na zwrot postaram się dostać 3080 i będę obserwować co z tymi Radeonami, ale cudów nie oczekuję.
    • Można prosić o rabat do tego laptopa?  https://www.x-kom.pl/p/604428-notebook-laptop-156-hp-15s-ryzen-5-4500-16gb-512-win10.html to ja proponuję ten
    • @Kyle_PL A jak jest ze skalowaniem gier? Dobrze to funkcjonuje czy są jakieś problemy? Coraz bardziej skłaniam się do tego WQHD, ale zastanawiam się w rozdzielczości 1440p w turówkach czy strategiach interfejs nie będzie zbyt mały. No i co jak będę chciał zagrać w grę której nie dam rady uruchomić w takiej rozdzielczości? Czy jak zejdę do FHD to będzie to dobrze wyglądało czy z takim skalowaniem w dół mogą być jakieś problemy w grach?
  • Aktywni użytkownicy

×
×
  • Dodaj nową pozycję...